Critical Update for Acrobat Reader

Most recent versions of Acrobat Reader, software used for viewing PDFs, contain serious security vulnerabilities. If you have this software installed, please visit Adobe’s website for security updates or select the update option from within the application.

Advertisements